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1. Inledning

OpenOffice Writer pdminner mycket om Microsoft Word vad det giller funktioner och
uppbyggnad. Till stor del gar det att gissa sig fram till vad man ska gora tack vare de beskrivande
namnen i menyer och de illustrerande knapparna. Men en del funktioner har visat sig lite svarare
an andra. Har kommer vi att beskriva ett par av dem som du kan komma att vilja anvidnda nér du
skriver rapporter eller dylikt.

Det finns flera skél att anvianda OpenOffice istéllet for Microsofts Office-paket. Ett ar att
OpenOffice innehéller en funktion for att snabbt omvandla dokumentet till en PDF-fil (se vidare
stycke 6). OpenOffice Writer dr for ménga tillimpningar lika bra som MS Word och nér det giller
ekvationshantering ar det till och med bittre (se stycke 4). Det allra basta med OpenOffice ir att
det dr helt gratis och finns tillgéngligt bdde for Windows, Linux och Mac. Det kan laddas ner
fran www.openoffice.org.

Instruktionerna nedan giller version 2.0 av OpenOffice Writer. Det dr den version som 1
november 2006 fanns i datorsalarna. Andra versioner av OpenOffice Writer kan skilja sig lite fran
denna vad det géller namn pa menyalternativ och liknande.

Den hér texten gor inte ngra som helst ansprék pa att vara en heltdckande OpenOffice-manual.
Snarare bor den ses som en samling tips som kan vara till nytta vid arbete i Fysikums
studentdatasalar. Om problem skulle uppstd, anvind d& OpenOffices inbyggda hjélpfunktioner,
eller titta pa Support-sidorna pa OpenOffices hemsida.



2. Svensk stavningskontroll for OpenOffice Writer

Nedan foljer en beskrivning for hur du installerar och anvinder den svenska stavningskontrollen
for OpenOffice Writer. Sjdlvfallet fungerar det dven for andra sprék. Da haller man Ctrl-knappen
nedtryckt samtidigt som man markerar fler sprak i spraklistorna.

Steg 1: Ladda ner de nodviandiga filerna

Vilj 'File' -> 'Wizards' -> 'Install new dictionary...'

Tryck pé texten 'Svenska'

Klicka pa 'Starta DicOOo'

Tryck 'Nasta'

Tryck pa 'Hamta hem listan 6ver tillgédngliga sprakfiler'. Detta hamtar listan med

rattstavningsordlistor.

Om programmet fragar om du vill anvdnda en nyare version av DicOOo, vilj 'No'.

Vilj 'Swedish (Sweden)' i listan och tryck 'Nasta'.

Tryck pa 'Hamta hem listan 6ver tillgédngliga sprakfiler' igen, den hir gangen hédmtas

avstavningsregler hem. Tryck 'Nista'

9. Tryck 'Nésta' pa en gang utan att trycka 'Hamta hem listan 6ver tillgéngliga sprakfiler'
eftersom det inte finns nagra synonymordlistor for svenska.

10. Tryck 'Nésta' och sedan 'Slutfor'

11. Starta om datorn. Detta gors for att OpenOffice ska hitta filerna.
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Steg 2: Still om till svensk stavningskontroll

Tools -> Options -> Language settings -> Writing aids

Tryck pa 'Edit..." under 'Available language modules'

Vilj 'Swedish (Sweden)' under 'Language'

Kryssa i rutorna under 'Spelling' & 'Hyphenation'

Tryck pa 'Close’

Vilj 'Languages' under 'Language settings' i menyn till véanster

Satt 'Locale setting' under 'Language of' till 'Swedish (Sweden)'

Satt "Western' under 'Default languages for documents' till 'Swedish (Sweden)'
Tryck 'OK'
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Steg 3: Att anviinda stavningskontrollen

Det finns tvé olika sitt att anvinda sig av stavningskontrollen

a) Vanlig stavningskontroll: 'Tools' -> 'Spellcheck...". Programmet kommer att fraga dig om de
ord det inte kénner igen.

b) Stavningskontroll medan du skriver: Tryck pa den lilla knappen som det stir 'ABC' pd med en
rod vagad rand undertill. Den kommer att markera alla ord som den inte kédnner till sedan
tidigare med en rod vagad rand. For att fa forslag pd hur ordet ska stavas, hogerklickar du pa
ordet.

3. Figurer och tabeller

Om du har infogat en ganska liten figur 1 din text och vill att 16ptexten ska flyta runt den kan du
vilja detta genom att hogerklicka pa figuren och vilja "Wrap'. Det passar bést for sma figurer, och
man bor se till att texten bara flyter péd en av figurens sidor, efter som texten blir svérldst annars.



3.1. Skapa en tabell- eller figurtext

Klicka pé figuren eller tabellen. Hogerklicka och
vélj 'Caption...". Skriv in figurtexten i rutan
'Caption'. Vilj 'Category' -> 'None'.

Andra typsnitt pa figurtexten: Klicka utanfor
figuren. Markera texten. Byt typsnitt och storlek
(rak stil, 2 punkter mindre &n I6ptexten
rekommenderas). Vilj 'more..." i formatlistan (féltet
dér det vanligtvis star 'Default' 1 dvre véinstra
hornet). Vilj 'New style from selection' -> "Update
style'.

3.2. "Luft" runt figurerna

Hogerklicka pa figurens ram (den tunna gra linjen
runt figuren och figurtexten). Vilj 'Frame' 1 menyn
('Picture' om du inte har nagon figurtext) och
Figur 1: En enkel figur ritad i OpenOffice Draw. dérefter fliken "Wrap'. Under rubriken 'Spacing' kan
Se nedan hur man infogar bilder frin OpenOffice du ¢ka avstandet mellan 16ptext och figur, vilket ar

Draw. Brodexten “flyter” runt figuren sé som  pephindigt speciellt nir du anvénder funktionen
beskrivs i texten hér intill. Wrap

Vill du ha storre avstand mellan figurtexten och figuren, hogerklickar du mitt pa figuren, viljer
"Picture' -> '"Wrap' och 0kar avstdndet under 'Spacing', 'Bottom'.

3.3. Infoga figur fran OpenOffice Draw

Om du ritar en figur med hjélp av OpenOffice Draw kan du inte infoga den direkt i ditt Writer-
dokument. Bilden maste forst exporteras till ett hanterligt filformat. Nér du har ritat din bild i
Draw kan du exportera den genom att vilja 'File' -> "Export'. Spara bilden med ett filformat som
OpenOffice Writer kdnner till, forslagsvis PNG, JPG eller GIF. Nu kan du infoga din bild i
OpenOffice Writer.

4. Ekvationshanteraren i OpenOffice Writer

Just ekvationshanteraren ar det som skiljer OpenOffice Writer mest fran MS Word. OpenOffice
ekvationshanterare heter OpenOffice Math. For att infoga en formel klickar man pd knappen
'Formula Editor' i menyraden eller, om den saknas, véljer man 'Insert' -> 'Object' -> 'Formula'.

Nu hénder en del saker: Dokumentfonstret delas i tva delar, dar den 6vre, stora delen visar
dokumentet s& som det kommer se ut utskrivet pa ett papper, medan det nedre fonstret visar
koden for formlerna. Dessutom dyker det upp en ruta som heter 'Selection'. Genom att klicka pa
olika alternativ i 'Selection'-rutan kan man se hur formelkodningen ser ut for just den matematiska

formeln. Om man exempelvis klickar pa symbolen % 1 rutan dyker texten <?> over <?>upp1

formelkodfonstret. Ersétt <?> med onskade bokstéver, siffror eller andra formeluttryck.
OBS! Ersditt inte bara frdagetecknet, utan hakparenteserna ocksa!

Om du rakar stdnga 'Selection'-rutan kan du hitta den igen under menyalternativet 'View', vilj
'Selection'.

OpenOffice Math avslutas genom att du klickar ndgonstans i texten utanfor formeln. Du kan
redigera en redan skriven formel genom att dubbelklicka péa den.



For nyborjaren ér det enklast att skriva formler med hjélp av 'Selection'-rutan men ganska snart
gér det snabbare att sjdlv skriva formelkodningen direkt 1 faltet lingst ner i fonstret. Hir kommer
nagra exempel pé formler och hur deras kodning ser ut. Prova sjdlv, utan att anvinda
'Selection'-rutan!

Formel Kodning
AB ABcC overline {AB} ~~ A size 16 B C
a2+ pi=c? a sup 2 + b sup 2 = c sup 2 newline
m p Y
alignl %$pi ~~ %$rho ~~ %PSI
N
Zxk left lbrace sum from{k=0} to{N} x sub k right none
k=0
n' C," n sup +{} ~~ C sub{r sub n}
142
Gng a partial {n}union csub{infinity} csup{l+2}{a}
a b . .
4 left ( matrix{a # b ## c # d} right )
c
bd
_”dxdy iint from{a c} to{b d} dx dy
V-VxB-4 nabla cdot nabla times nitalic bold B cdot A

Nar du har skrivit en del formler i OpenOffice kommer du att mérka att det gar mycket fortare 4n
i MS Words Equation Editor.

Om du behover hjilp medan du héller pa med OpenOffice Math finns en hjélpfunktion tillgénglig
om du gér till menyn 'Help' och viljer 'OpenOffice Help'. I den hogra delen av fonstret som
kommer upp kan du sedan vilja 'Formula reference', d.v.s. du kommer till formelreferenshjélpen.

4.1. Andra mellanrummet runt formler

Nar du skriver formler 1 16pande text &r det snyggt om du tar bort det extra mellanrummet som
uppstar runt formlerna. Detta gér du genom att i menyn 'Format' vélja 'Styles and Formatting'. I
fonstret som dyker upp klickar du pa 'Frame Styles' vilket dr den tredje knappen i den dvre raden.
Hogerklicka sedan pd 'Formula' 1 listan och vélj 'Modify'. I fonstret som dyker upp finns det en
menyrad med alternativet "Wrap'. Denna klickar du pé och stéller in 6nskat avstdnd runt
formlerna.



5. Numrering och formatmallar

5.1. Sitt in och modifiera sidnumrering

For att kunna ha sidnumrering maste du forst skapa en sidfot lingst ner pé sidan. Detta gor du
genom att ga till 'Footer' i 'Insert'-menyn och dér vélja 'Default'. For att sedan ldgga in
sidnumreringen, sitter du pekaren 1 detta filt och viljer i 'Insert'-menyn 'Field' foljt av 'Page
number'. Om du istéllet vill ha sidnumreringen hdgst upp pa sidan gor du likadant, bortsett fran
att du anvénder 'Header' istéllet for 'Footer'.

Om du vill borja sidnumreringen forst pa andra sidan kan du dubbelklicka pa sidnumret péd en av
sidorna och 1 rutan som dyker upp satta 'Offset' till -1.

Det dr dven mgjligt att ta bort utskriften av sidnumret pa en sida (utan att for den skull inte rdkna
sidan). Detta kan man gora genom att stélla pekaren pa den aktuella sidan och sedan i
'Format'-menyn vilja 'Styles' and 'Formatting'. En ruta dyker upp i vilken du véljer 'Page styles',
vilket dr den 4:e knappen pa den 6vre raden. Dubbelklicka nu pé 'First page' i listan vilket
definierar den markerade sidan som en forsta sida. Hogerklicka sedan pa 'First page' och vilj
'Modify...". I fonstret som dyker upp véljer du 'Default’ i féltet for 'Next style'. Detta gor att du
definierar den efterfoljande sidan som en normal' sida.

5.2. Skapa numrerade rubriker och infoga innehéllsforteckning

Det &r alltid bra att formattera sina rubriker, inte bara genom att dndra storlek och typsnitt, utan
ocksa genom att tala om for ordbehandlingsprogrammet att det &r en rubrik. I OpenOffice gor
man det genom att markera rubriken och vélja 'Heading 1' (eller 'Heading 2', eller...) i rullisten 1
Ovre vénstra delen av fonstret, dir det vanligtvis star 'Default'.

For att dndra en av de fordefinierade rubrikerna borjar du med att formattera rubriken i1 den gamla
stilen. Andra formatteringen (t.ex. font och storlek). Vilj "More' i rullisten och tryck pa symbolen
langst till hoger. Vilj 'Update Style' i den rullist som kommer upp.

Rubrikerna numreras genom att man viljer 'Tools' -> 'Outline numbering'. Vilj vilken rubrik som
ska numreras och vilken typ av numrering du vill ha.

For att infoga innehéllsforteckning véljer du 'Insert' -> 'Indexes and tables' -> 'Indexes and tables'.
Vilj 'Type': Table of Contents och dndra texten i rutan 'Title' till “Innehéll” (om du skriver pa
svenska). Den kan dven vara bra att avmarkera rutan 'Protect against manual changes', eftersom
det ibland &r bra att kunna dndra 1 innehéllsforteckningen.

5.3. Automatisk uppdatering av tabellnummer

For att l4gga in ett tabellnummer som automatiskt uppdateras ska du vilja 'Fields' och 'Other..." i
'Insert'-menyn. Ett fonster dyker upp i vilket du ska markera 'Variables'. I tabellen "Type' viljer du
sedan 'Number range' och i tabellen 'Selection' véljer du 'Table'. Sedan anger du hur du vill att
tabellnumreringen ska ga till.

5.4. Formatmallar

Det ér praktiskt att kunna spara sina formatmallar, eftersom man inte vill gora alla &ndringar av
rubrikstilar med mera varje gang. Nér man ar student och stindigt jobbar med olika datorer 4r det
allra behéndigast att ha ett malldokument (t.ex. for labbrapporter) i vilket man skriver sina
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rapporter.

Skapa en fil rapportmall.odt, dér du gor dina dndringar. Varje gang du ska skriva en ny labrapport
kan du 6ppna filen, spara den med det nya filnamnet (t.ex. labb1.odt) och darefter skriva din
rapport.

Lagg till en ny knapp (t.ex. for att infoga formler) som sparas i filen:

Ga till 'Tools' i menyraden och vélj 'Customize...". Vilj 'Save in' -> rapportmall.odt. Légg till nya
knappar (menyn 'Tools' -> 'Customize' -> 'Toolbars'. Markera 6nskade knappar och avsluta med

att klicka 'OK"). Nu har dndringarna sparats i dokumentet, och kommer finnas dar oavsett var du
Oppnar det. Samma sak giller dndrade rubrikstilar och liknande.

6. Exportera till PDF

Da du skriver en rapport eller dylikt i OpenOftfice Writer och vill gora resultatet tillgéngligt for
andra personer gor du bist 1 att forst omvandla den till en PDF-fil (Portable Document Format).
Detta beror pé att den som ska ldsa kanske inte har OpenOffice och ppnar den i Microsoft Word
istdllet eller 1 en annan version av OpenOffice Writer varvid formler och tecken kan bli felaktiga.
Om du didremot skickar filen som PDF kan du vara siker pd att den som ldser filen ser exakt
samma sak som du skickade.

For att omvandla en fil i OpenOffice Writer till PDF klickar du pé knappen 'Export directly as
PDF' som finns 1 verktygsraden. Ange vilket namn PDF-filen ska ha och klicka pd 'Export’. Om
knappen saknas viljer du istéllet 'Export as PDF' i 'File'-menyn. I en del versioner finns inte denna
utan man kan istéllet gd till 'Print..." i 'File'-menyn och under 'Name' sedan vilja 'Adobe PDF".



